[squid-users] External ACL

avi_h harariboy at gmail.com
Wed May 24 20:16:39 UTC 2017

So I managed to create the SQL table after reviewing the script.
When testing the script outside of squid I get an OK reply.
When I tested with squid I got the same error message as before (queue
After some more investigating I managed to resolve that.
What solved it was adding ipv4 to the external_acl_type line.
I was then able to run my own scripts as well.
But now I'm getting the following error:

2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(786) aclMatchExternal:
ip_checker("") = lookup needed
2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(789) aclMatchExternal:
"": queueing a call.
2017/05/24 20:28:57.084 kid1| 28,2| Checklist.cc(129) goAsync: 0x2af3658 a
slow ACL resumes by going async again! (loop #0)
2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(1416) Start: fg lookup
in 'ip_checker' for ''
2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(792) aclMatchExternal:
"": return -1.

Any ideas?


View this message in context: http://squid-web-proxy-cache.1019090.n4.nabble.com/External-ACL-tp4682519p4682555.html
Sent from the Squid - Users mailing list archive at Nabble.com.

More information about the squid-users mailing list