[squid-users] External ACL

Amos Jeffries squid3 at treenet.co.nz
Wed May 24 20:53:06 UTC 2017

On 25/05/17 08:16, avi_h wrote:
> So I managed to create the SQL table after reviewing the script.
> When testing the script outside of squid I get an OK reply.
> When I tested with squid I got the same error message as before (queue
> overload).
> After some more investigating I managed to resolve that.
> What solved it was adding ipv4 to the external_acl_type line.

Ah, darnit. I forgot about that one. Been years since anyone had a 
broken localhost interface.

> I was then able to run my own scripts as well.
> But now I'm getting the following error:
> 2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(786) aclMatchExternal:
> ip_checker("") = lookup needed
> 2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(789) aclMatchExternal:
> "": queueing a call.
> 2017/05/24 20:28:57.084 kid1| 28,2| Checklist.cc(129) goAsync: 0x2af3658 a
> slow ACL resumes by going async again! (loop #0)
> 2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(1416) Start: fg lookup
> in 'ip_checker' for ''
> 2017/05/24 20:28:57.084 kid1| 82,2| external_acl.cc(792) aclMatchExternal:
> "": return -1.
> Any ideas?

Its not an error, just debug info stating what is happening. Multiple 
loops are a bit surprising but can happen.

If you have two async ACLs on the one http_access line it is normal. Or 
if you are trying to pass %LOGIN to the external ACL helper without 
first having authenticated it is normal. There may be other cases I'm 
not familiar with too.


More information about the squid-users mailing list