[squid-users] Linking with *SSL

Amos Jeffries squid3 at treenet.co.nz
Fri May 20 14:06:48 UTC 2016

On 13/05/2016 1:33 a.m., Spil Oss wrote:
>> Hi!
>> When we worked on squid port on FreeBSD one of the FreeBSD user
>> (Bernard Spil) noticed:
>> When working on this, I ran into another issue. Perhaps maintainer can
>> fix that with upstream. I've now added LIBOPENSSL_LIBS="-lcrypto
>> -lssl" because of configure failing in configure.ac line 1348.
>>> AC_CHECK_LIB(ssl,[SSL_library_init],[LIBOPENSSL_LIBS="-lssl $LIBOPENSSL_LIBS"],[AC_MSG_ERROR([library 'ssl' is required for OpenSSL])
>> You cannot link against libssl when not linking libcrypto as well
>> leading to an error with LibreSSL. This check should add -lcrypto in
>> addition to -lssl to pass.
>> Is this something someone could take a look at?
> Hi All,
> Sorry for replying out-of-thread.
> What happens is that the check for SSL_library_init fails as -lcrypto
> is missing.
> Output from configure
>> checking for CRYPTO_new_ex_data in -lcrypto... yes
>> checking for SSL_library_init in -lssl... no
>> configure: error: library 'ssl' is required for OpenSSL
>> ===>  Script "configure" failed unexpectedly.
> What I usually see in autoconf scripts is that temp CFLAGS etc are set
> before the test for SSL libs and reversed after the test.
> Adding LIBOPENSSL_LIBS="-lcrypto -lssl" to configure works as well
> Would be great if you can fix this!

Hi, sorry for the long delay. Its been an interesting month.

It seems we need to now stop relying on LIBS being set correctly by
autoconf when consecutive AC_CHECK_LIB are done. I'm trying out a fix
now and which should be in the next releases.

FYI: Squid is increasingly using the pkg-config tool for resolving odd
library dependencies. If it is available this broken check will never be


More information about the squid-users mailing list