[squid-users] Need help with Squid on Windows

Rafael Akchurin rafael.akchurin at diladele.com
Sat Apr 23 16:19:37 UTC 2016

Hello Yuri and all,

I would then try the process monitor that will most probably give an answer why the perl exe helper does not start. 

Best regards,

-----Original Message-----
From: squid-users [mailto:squid-users-bounces at lists.squid-cache.org] On Behalf Of Yuri Voinov
Sent: Saturday, April 23, 2016 4:57 PM
To: squid-users at lists.squid-cache.org
Subject: Re: [squid-users] Need help with Squid on Windows

Hash: SHA256

I can confirm - perl helpers (I've tried to use store-ID with Active
Perl) does not work with Win version of Squid. I've tried to configure it several times. Without success. With the same symptoms.

WBR, Yuri

23.04.16 18:26, Rafael Akchurin пишет:
> Hello Jason, Amos, all,
> Possibly the issue can be related to Squid being compiled with Cygwin
https://cygwin.com/ml/cygwin/2012-03/msg00302.html, I'm not sure whether this issue with standard output has been fixed in the current Cygwin.
> One of the workarounds that could possibly work is to install Cygwin
and build squid yourself as described here:
http://docs.diladele.com/tutorials/build_squid_windows/index.html, this should start helpers from Cygwin terminal instead of cmd.
> Best regards,
> Rafael Akchurin
> Diladele B.V.
> http://www.quintolabs.com
> http://www.diladele.com
> --
> Please take a look at Web Safety - our ICAP based web filter server
for Squid proxy at http://www.diladele.com.
> -----Original Message-----
> From: squid-users [mailto:squid-users-bounces at lists.squid-cache.org]
On Behalf Of Amos Jeffries
> Sent: Saturday, April 23, 2016 5:42 AM
> To: squid-users at lists.squid-cache.org
> Subject: Re: [squid-users] Need help with Squid on Windows
> On 23/04/2016 3:09 a.m., Jason Spegal wrote:
>> Hello all,
>> I need help with an issue that is now beyond me. I've installed squid
>> 3.5.16 (From: http://squid.diladele.com/) on my Windows 10 laptop, 
>> and I'm trying to enable the URL Rewrite helpers that I wrote in perl 
>> for my linux server. I've already done the necessary adjustments to 
>> them to make them work on windows. Running them directly seems to be 
>> fine, however when squid runs them they fail to execute. I've gotten 
>> as far as finding out perl is executing okay, however the script is 
>> not. I am unable to figure out how to debug it further. Running squid 
>> with full debugging (squid.exe -N -X -d 7) did not produce any 
>> significant information as to why they were not executing.
> You usually need to enable debugging in the helper itself to get that.
> Squid only knows that the helper died on startup.
>> My linux server is
>> running squid 3.5.11 and is not having any issues with the helpers.
>> The very first thing the helpers do is open a log file and write an 
>> initialization statement to it. I'm not seeing this when squid tried 
>> to execute it, so I'm fairly certain it has something to do with the 
>> execution of the script rather than a problem with the script itself.
>> I've also examined the permissions, and those should be good.
> FWIW: Nothing has changed inside Squid for helpers between those two
>> Thanks in advance for the help.
>> --Jason
>> squid.conf
>> -------------------------------------------
>> url_rewrite_program /cygdrive/c/strawberry/perl/bin/perl.exe
>> C:\Squid\etc\squid\filtered_sites\squidRed.pl
>> url_rewrite_children 100 startup=10 idle=1 concurrency=10 
>> url_rewrite_access allow all url_rewrite_bypass off
>> Also tried url_rewrite_program
>> /cygdrive/c/squid/etc/squid/filtered_sites/squidRed.pl
>> cache.log
>> -------------------------------------------
>> Squid Cache (Version 3.5.16): Terminated abnormally.
> Maybe something left over from this previous aborted Squid instance
and its helpers that kills the next one to start?
>> CPU Usage: 0.281 seconds = 0.078 user + 0.203 sys Maximum Resident
>> Size: 1371136 KB Page faults with physical i/o: 5488
>> 2016/04/22 08:53:06 kid1| Set Current Directory to 
>> /cygdrive/c/squid/var/cache/squid
>> 2016/04/22 08:53:06 kid1| Starting Squid Cache version 3.5.16 for 
>> x86_64-unknown-cygwin...
> ...
>> 2016/04/22 08:53:06 kid1| helperOpenServers: Starting 10/100 'perl.exe'
>> processes
> ...
>> 2016/04/22 08:53:06 kid1| WARNING: redirector #Hlpr6 exited
> ...
>> 2016/04/22 08:53:06 kid1| Too few redirector processes are running 
>> (need
>> 1/100)
> ...
>> FATAL: The redirector helpers are crashing too rapidly, need help!
> Note that it is only the 6th helper that dies. The first 5 seem to be
okay at this point.
> Maybe something they share which has a limited connection count?
> Amos
> _______________________________________________
> squid-users mailing list
> squid-users at lists.squid-cache.org
> http://lists.squid-cache.org/listinfo/squid-users
> _______________________________________________
> squid-users mailing list
> squid-users at lists.squid-cache.org
> http://lists.squid-cache.org/listinfo/squid-users

Version: GnuPG v2

More information about the squid-users mailing list