[squid-users] Need help with Squid on Windows

Amos Jeffries squid3 at treenet.co.nz
Sat Apr 23 03:41:31 UTC 2016

On 23/04/2016 3:09 a.m., Jason Spegal wrote:
> Hello all,
> I need help with an issue that is now beyond me. I've installed squid
> 3.5.16 (From: http://squid.diladele.com/) on my Windows 10 laptop, and
> I'm trying to enable the URL Rewrite helpers that I wrote in perl for my
> linux server. I've already done the necessary adjustments to them to
> make them work on windows. Running them directly seems to be fine,
> however when squid runs them they fail to execute. I've gotten as far as
> finding out perl is executing okay, however the script is not. I am
> unable to figure out how to debug it further. Running squid with full
> debugging (squid.exe -N -X -d 7) did not produce any significant
> information as to why they were not executing.

You usually need to enable debugging in the helper itself to get that.
Squid only knows that the helper died on startup.

> My linux server is
> running squid 3.5.11 and is not having any issues with the helpers. The
> very first thing the helpers do is open a log file and write an
> initialization statement to it. I'm not seeing this when squid tried to
> execute it, so I'm fairly certain it has something to do with the
> execution of the script rather than a problem with the script itself.
> I've also examined the permissions, and those should be good.

FWIW: Nothing has changed inside Squid for helpers between those two

> Thanks in advance for the help.
> --Jason
> squid.conf
> -------------------------------------------
> url_rewrite_program /cygdrive/c/strawberry/perl/bin/perl.exe
> C:\Squid\etc\squid\filtered_sites\squidRed.pl
> url_rewrite_children 100 startup=10 idle=1 concurrency=10
> url_rewrite_access allow all
> url_rewrite_bypass off
> Also tried url_rewrite_program
> /cygdrive/c/squid/etc/squid/filtered_sites/squidRed.pl
> cache.log
> -------------------------------------------
> Squid Cache (Version 3.5.16): Terminated abnormally.

Maybe something left over from this previous aborted Squid instance and
its helpers that kills the next one to start?

> CPU Usage: 0.281 seconds = 0.078 user + 0.203 sys
> Maximum Resident Size: 1371136 KB
> Page faults with physical i/o: 5488
> 2016/04/22 08:53:06 kid1| Set Current Directory to
> /cygdrive/c/squid/var/cache/squid
> 2016/04/22 08:53:06 kid1| Starting Squid Cache version 3.5.16 for
> x86_64-unknown-cygwin...
> 2016/04/22 08:53:06 kid1| helperOpenServers: Starting 10/100 'perl.exe'
> processes
> 2016/04/22 08:53:06 kid1| WARNING: redirector #Hlpr6 exited
> 2016/04/22 08:53:06 kid1| Too few redirector processes are running (need
> 1/100)
> FATAL: The redirector helpers are crashing too rapidly, need help!

Note that it is only the 6th helper that dies. The first 5 seem to be
okay at this point.

Maybe something they share which has a limited connection count?


More information about the squid-users mailing list