[squid-users] Reverse Proxy Funny Logging Issue

Amos Jeffries squid3 at treenet.co.nz
Sat Mar 14 05:14:06 UTC 2015

On 14/03/2015 5:19 a.m., dweimer wrote:
>> Last night I applied the FreeBSD 10.1-RELEASE-p6 Update and Upgraded
>> the ports which included Squid 3.4.12, I enabled the LAX HTTP option
>> in the ports configuration with adds the --enable-http-violations
>> compile option. With the intention to enable broken_posts option in
>> the configuration. I will hopefully be able to apply any necessary
>> changes to the production system after I test them now.
>> When doing this update I did have a thought the system is running in a
>> FreeBSD jail and not on the base system is there a chance this issue
>> is caused by running within a jail? curious if anyone has ran into
>> specific issues running Squid in a FreeBSD jail before?
> Well I am at a loss, debugging hasn't led to anything more than a
> timeout occurs. I was able to create a test PHP form to upload files on
> an Apache server and upload up to a 264MB file. I didn't try any larger
> files though I suspect it would work up to the configured 1024MB that I
> had Apache configured for. So its not all HTTPS only those files going
> to our OWA and Sharepoint servers. The only settings I can find that
> changes the behavior at all is to change the "write_timeout" to
> something smaller, like 45 seconds and then it errors sooner instead of
> taking forever to give up.
> I tried uninstalling the Squid 3.4 FreeBSD port and using the 3.3 port
> instead on the test system, no change. I also tried installing 3.5 from
> source using the same configure options that my 3.4 port returned with
> squid -v, again no change.
> I have verified that the IIS logs show a client request timeout has
> occurred, the broken_posts allow didn't create any change in behavior. I
> do know that if I point the browser directly to the Exchange server it
> works, so its only broken going through the reverse the proxy. If I
> point the browser through a forwarding Squid proxy that knows how to
> talk directly to the exchange server instead of the reverse proxy it
> works with no special settings. If I post a large debugging file to a
> website do I have any volunteers to look at it and see if they can see
> what's going on?

It sounds like its not actually a Squid problem. There is enough code
churn between the major versions you tried that things should have
changed between them.

Could it be the end-of-line issue in Python?


More information about the squid-users mailing list