[squid-users] Unable to access websites through Squid

dolson at ihcrc.org dolson at ihcrc.org
Wed Dec 23 15:26:26 UTC 2015


I am working with Squid 3.4.8 on a Debian 8.2 system.   The goal is to record all web activity, not block any sites at this time utilizing squid.  I have followed several different sets of instructions on setting up Squid to utilize Active Directory Authentication to record who goes where.   I have yet to be able to access any websites, even internal sites while passing through the Squid Proxy.   The browser I'm testing on is Mozilla Firefox 42.0 on a Windows 7 Professional system.  I am using Firefox for testing as I can set the proxy without affecting my other browsers on my workstation.

I have tried various different forms of the squid.conf file, found from various sources and I have yet to get a successful connection.  Depending on the file configuration I use, I am getting an "access denied" page from the squid server, or a "Problem loading page:  The connection was reset" error.   With the current squid.conf, which brings up the second error, nothing is recorded in the access.log file, and the cache.log file keeps reporting the following error:

WARNING:  memberof #Hlpr0 exited
FATAL:  The memberof helpers are crashing too rapidly, need help!

I feel like I'm banging my head against the wall at this point.   I have tried slowly building the squid.conf file, adding one authenticator program at a time until I got some sort of different response and I have not been able to get anything to work.

I have attached several different squid.conf files that I have used.  The current "Squid.conf" file generates the "Connection was reset" error message, while the squid.conf.bk5 file just gives me an access is denied message.

Please help!

Thank you,

Dan Olson
Indian Health Care Resource Center
Network Support Specialist
Main: 918.588.1900 Ext. 2212
Direct: 918.382.1212

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.squid-cache.org/pipermail/squid-users/attachments/20151223/3460e340/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: squid.conf.bk5
Type: application/octet-stream
Size: 2200 bytes
Desc: squid.conf.bk5
URL: <http://lists.squid-cache.org/pipermail/squid-users/attachments/20151223/3460e340/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: squid.conf
Type: application/octet-stream
Size: 3333 bytes
Desc: squid.conf
URL: <http://lists.squid-cache.org/pipermail/squid-users/attachments/20151223/3460e340/attachment-0001.obj>

More information about the squid-users mailing list