[squid-users] Squid 3.5.28 can't be built on FreeBSD 12.0-RELEASE

Amos Jeffries squid3 at treenet.co.nz
Tue Dec 25 13:30:49 UTC 2018


On 24/12/18 11:41 pm, Marko Cupańá wrote:
> Hi,
> 
> it appears that Squid 3.5.28 (current FreeBSD port for www/squid3)
> can't be built on latest FreeBSD release. The problem appears to be
> related to openssl version in FreeBSD base, which is "OpenSSL
> 1.1.1a-freebsd  20 Nov 2018" according to `openssl version`.
> 
> Are there plans to patch Squid 3.5.X so it works on FreeBSD 12-RELEASE?
> 

No. Squid-3.5 is no longer supported for anything but security
vulnerabilities.

The current production series (Squid-4) already contains all the code
re-writes for use with OpenSSL-1.1.

Amos


More information about the squid-users mailing list