[squid-users] Errors Compiling Squid Proxy on Windows using Cygwin

Amos Jeffries squid3 at treenet.co.nz
Mon Dec 17 01:36:39 UTC 2018

On 15/12/18 8:52 am, Russel McDonald wrote:
> Hi,
>  I’ve followed the small set of steps for building squid proxy using
> Cygwin on Windows 7 but am getting compile time errors. Specifically the
> below. Sorry for emailing this question if this has been answered. I
> searched past emails and the most recent hit on errors building on
> Windows was from 2010.
> Cygwin version 2.11.2 from Nov 8/2018 and installed ALL features
> including devel.
> Downloaded squid source, tar –xvf  squid-3.5.11.tar.gz (I tried version
> 3.5.28 as well)
> ./configure --bindir=/bin/squid --sbindir=/usr/sbin/squid
> --sysconfdir=/etc/squid    --datadir=/usr/share/squid
> --libexecdir=/usr/lib/squid --disable-strict-error-checking   
> --with-logdir=/var/log/squid --with-swapdir=/var/cache/squid
> And tried with --enable-win32-service as well.
> Then make produces the error below. What am I doing incorrectly?

Your Squid is detecting the existence of Windows OS headers and trying
to build a helper which has bugs in your environment.

This type of problem is why the Diladele Cygwin instructions (and other
OS cross-building) list the helpers to build explicitly whereas native
builds can just use the auto-detect by ./configure. Doing the same for
your build will both avoid this issue and reduce the size of your Squid

Please open a bug report in our bugzilla about this so it does not get
forgotten. I am not aware of anyone working on Windows bugs right now so
no ETA on when it might get fixed.


More information about the squid-users mailing list