[squid-users] Only listening to ipv6 (bug) still present? http_port IGNORE PEBCAK

Tory M Blue tmblue at gmail.com
Wed May 4 03:22:04 UTC 2016

On Tue, May 3, 2016 at 5:58 PM, Amos Jeffries <squid3 at treenet.co.nz> wrote:
> On 4/05/2016 11:12 a.m., Tory M Blue wrote:
>> My configs have always consisted of http_port 80 accel vhost.. With
>> the latest 3.5.17 (I guess) if you don't list squid won't
>> even attempt to listen, talk on ivp4..
>> So adding allows it to at least talk via ipv4.
>> This seems wrong, odd.
>> I understand you are removing methods to disable ipv6, however forcing
>> folks to us only ipv6 seems like a stretch :)
>> Thanks
>> Tory
>> CentOS 7
>> squid-3.5.17-1.el7.centos.x86_64
> What is Squid saying on startup about the stack type detected?
>  (may have to set debug_options 3,2)
> Linux has a hybrid TCP stack. Which means IPv6 ports can receive IPv4
> traffic unless you change something. Have you got any custom config in
> your TCP/IP settings that might have changed the stacks v4-mapping
> behaviour?
> Amos

Hey Amos

Other than disabling ipv6, there are no other tweaks.  The output of
netstat showed [::] 80 (what my squid servers listen on), but it
didn't seem to want to respond when I hit the squid server with a
request via ipv4.

As I mentioned I added and it worked, worked with
my.ip.address.here:80 as well.. But just having port 80 there I got

Let me test again, before I hit send.... <elevator music of the most
annoying kind......>

Well #$%#%$#%$#%$ it's working now. I must have had the issues before
I made some other "network related changes" and didn't correlate the

tcp6       0      0 :::80                   :::*                    LISTEN

Allows for my port 80 requests as you stated..

Please pardon me for this interruption. I even stopped the service and
restarted, it works. I sent this so early with so many other changes,
I just didn't correlate my other actions.

My apologies


More information about the squid-users mailing list