[squid-users] Squid3 error: CHILD: hello write test failed logrotate

Antony Stone Antony.Stone at squid.open.source.it
Wed Jun 22 13:53:30 UTC 2016

On Wednesday 22 June 2016 at 15:44:42, Roberto Carna wrote:

> Dear Antony, thanks for your help..below is the
> /etc/logrotate.d/squid3 file....but before I have to say I've seen in
> the web that this problem is solved by enabling IPv6, and was reported
> by a ticket (https://forum.opnsense.org/index.php?topic=879.0) ..can
> this be true???

1. Have you tried to disable IPv6 on this machine?  (see my other reply to 
your other reply)

2. You said in your first posting that "I have to create the access.log by 
hand, and set up the owners. After that I rebooted the server and squid3 
daemon runs OK."  Do you really need to reboot the server, or is restarting 
Squid sufficient?

> /var/log/squid3/*.log {
>         daily
>         compress
>         delaycompress
>         rotate 2
>         missingok
>         nocreate
>         sharedscripts
>         postrotate
>                 test ! -e /var/run/squid3.pid || test ! -x
> /usr/sbin/squid3 || /usr/sbin/squid3 -k rotate
>         endscript
> }

Considering that you've found you have to create the file manually and set the 
correct permissions / ownerships, I would change the "nocreate" line in the 
above script so that it does create the file, with the correct ownership etc.



Never write it in Perl if you can do it in Awk.
Never do it in Awk if sed can handle it.
Never use sed when tr can do the job.
Never invoke tr when cat is sufficient.
Avoid using cat whenever possible.

                                                   Please reply to the list;
                                                         please *don't* CC me.

More information about the squid-users mailing list