[squid-users] Sibling cache returns 504 when accessing cached objects

Amos Jeffries squid3 at treenet.co.nz
Thu Apr 14 00:36:34 UTC 2016

On 14/04/2016 4:28 a.m., Tomas Mozes wrote:
> On Wed, Apr 13, 2016 at 5:39 PM, Amos Jeffries <squid3 at treenet.co.nz> wrote:
>> On 14/04/2016 2:23 a.m., Tomas Mozes wrote:
>>> I checked upstream (up.example.com) and there was no connection attempt.
>>> Tried with ICP/HTCP, same result. I'm not sure, is this bug
>>> http://bugs.squid-cache.org/show_bug.cgi?id=4223?
>> I think it is, yes.
>> Amos
> Can I supply any more information to help fixing this?

There is a quick-fix and a full fix.

* The quick fix would be to just remove the "only-if-cached" from
sibling lookups. That would let the sibling revalidate. Queries would
result in 200 or such 'successfully', but much slower than they should.

* The full fix for good performance we still need someone to get a ALL,9
debug trace from both proxies and then to figure out from that;
 A) why the sibling is trying to do 304 revalidation on the full fetch
instead of identifying such problems on the HTCP lookup, and
 B) why the front proxy is not doing failover properly on the 504
response it gets back.


More information about the squid-users mailing list