[squid-users] Squid is not worked in OpenVZ VPS.

Billy.Zheng (zw963) zw963 at 163.com
Wed Dec 30 10:39:12 UTC 2015

Hi, I have two VPS in same location(HONG KONG)

the two VPS is blongs to two service provider, one OpenVZ, one XEN.

I choice with same version CentOS(6.7), and with same config script for
a FORWARD proxy to access free world.

XEN always worked for me, but OpenVZ is not.

following is some simple description:

I start squid with a https port(11223), and I can access squid server
from my local host with stunnel/telnet in both VPS.

But, only zhe XEN vps can forward my request to my destination host.

I access www.google.com from my local browser, will see following logs:

>> 1451383747.833 19921 TCP_MISS/000 0 GET http://www.google.com/ - DIRECT/www.google.com -
>> 1451383819.941 61710 TCP_MISS/503 0 CONNECT www.vpsnine.com:443 - DIRECT/2400:cb00:2048:1::6819:341f -
>> ...

the second logs is so strange,  www.vpsnine.com is my OpenVZ VPS
provider domain name, I never access it from my local browser.
and not like another XEN VPS, those log output is very very slow.

Could you give me some clue for resolve this? Thanks.
Geek, Rubyist, Emacser
Homepage: http://zw963.github.io

More information about the squid-users mailing list