<div dir="ltr"><div><div>HI,<br></div>  the low-hanging fruits from Coverity's analysis have been picked, now working on somewhat more complex fixes.<br>The attached patch takes a hint from two benign coverity defects to:<br></div><div>- rework the berEncodeLoginData error handling path to be more readable<br></div><div>- refactor Digest auth's field lookup table to use a std::map instead of abusing httpHeaderFieldsInfo; this improves readability and size of the code, and has the added small bonus of lowering the lookup cost from linear to logarithmic<span style="font-family:monospace"><br></span><br></div><div>the Digest code  has been run-tested. I'd like feedback on its style, as httpHeaderFieldsInfo is abused similarly elswehere and I'm considering to apply it elsewhere as well; it can then be further refined to get O(1) via a carefully-chosen hash (via std::unsorted_map)<br><br></div><div>-- <br><div>    Francesco</div>
</div></div>