<div dir="ltr"><br><div class="gmail_extra"><br><div class="gmail_quote">On Fri, Jul 10, 2015 at 2:39 PM, Amos Jeffries <span dir="ltr"><<a href="mailto:squid3@treenet.co.nz" target="_blank">squid3@treenet.co.nz</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><div class=""><div class="h5">On 10/07/2015 3:18 a.m., Kinkie wrote:<br>
> Hi,<br>
>   I'm going through the issues identified by Coverity Scan, in<br>
> chronological order.<br>
> This patch covers 11 defects, mostly unchecked return values. It also<br>
> converts unlinkd to c++ (original defect: using tainted strings). They have<br>
> all build-tested; unlinkd has been (hand)-run tested.<br>
><br>
<br>
</div></div>Audited on IRC, summary below:<br>
<br>
in src/DiskIO/AIO/AIODiskIOStrategy.cc does the change actually do<br>
anything useful?<br>
 - the entire function is dead code due to the return-0 that starts it.<br>
 - thats why I marked that issue as intentional to be ignored.<br>
 - Ive been contemplating making it #if 0 wrapped for coveritys pleasure.<br></blockquote><div><br></div><div>Gah, right. #0-ed the whole function body<br></div><div> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
in src/DiskIO/DiskDaemon/DiskdFile.cc I thought you were going to use<br>
the unlock() result inline for the if-statement, the variable seems<br>
unnecessary since its not even used in the debug statement<br></blockquote><div><br></div><div>I've used a variable for readability; I can refactor no problem. As the variable is const, I expect it to be optimized away anyway. Do you wish me to?<br></div><div> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
in src/debug.cc (or anywhere else) please dont use xstrerror() anymore.<br>
 - use xstrerr(errno) instead. since the debugs() initilization<br>
overwrites errno value.<br></blockquote><div><br></div><div>Done<br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
 - also at that point in src/debug.cc the debugs() log file is closed.<br>
  = at least on Windows builds. have to report errors to stderr instead<br>
until we fix debugs() to store in a temporary buffer when waiting on<br>
cache.log existence (that could be an XXX comment).<br></blockquote><div><br></div><div>via std::cerr or some other mechanism?<br></div><div> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
in src/ipc.cc the conventions Ive been using is to name the sockopt<br>
which failed. ie debugs(..."setsockopt(FOO) failed: " << xstrerr(errno))<br></blockquote><div><br></div><div>Done.<br></div><div> </div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
in src/unlinkd_daemon.cc #include statements aphabetical please. helps<br>
avoid a reformat followup commit.<br>
- can you double-check the removal of setbuf() please? AFAIK the<br>
iostreams still need un-buffering and theres no iostreams way to do it.<br></blockquote><div><br></div><div>std::endl flushes the output buffer (from <a href="http://en.cppreference.com/w/cpp/io/manip/endl">http://en.cppreference.com/w/cpp/io/manip/endl</a> : <br>"Inserts a newline character into the output sequence <code>os</code> and flushes it as if by calling <span class=""><span class="">os.<span class="">put</span><span class="">(</span>os.<span class="">widen</span><span class="">(</span><span class="">'<span class="">\n</span>'</span><span class="">)</span><span class="">)</span></span></span> followed by <span class=""><span class="">os.<span class="">flush</span><span class="">(</span><span class="">)</span></span></span>."</div><div> <br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
thats all I think. thank you.<br>
</blockquote></div><br><br clear="all"><br>-- <br><div class="gmail_signature">    Francesco</div>
</div></div>