[squid-dev] To make squid works in snap world.
rousskov at measurement-factory.com
Fri Mar 17 15:04:20 UTC 2017
On 03/17/2017 02:05 AM, Gary Wang wrote:
> I made another change to keep new DEFAULT_IPC_PREFIX
> consistent in src/ipc/Port.cc file.
> Could you guys help review the MP?
I can only repeat what I have already said:
> Why not make DEFAULT_STATEDIR configurable instead? (If we do make
> it configurable, we may need to renamed it to STATEDIR, IPCDIR, or
> something like that but that is a separate and minor issue.)
and, later, a design sketch detailing the above suggestion:
> Can the updated/renamed DEFAULT_STATEDIR be interpreted as
> <path> / <filename prefix>
> where the first component is used if and only when nameIsPath is true
> and the second component is optional? AFAICT, such an implementation
> would cover the already supported use cases and your new use case.
> For snap environments, the option could be set to something like:
I do not know whether you consider the above design broken or inferior
to yours -- AFAIK, you have not addressed these comments/concerns.
More information about the squid-dev