[squid-dev] [PATCH] Purge cache entries in SMP-aware caches

Amos Jeffries squid3 at treenet.co.nz
Sat Aug 5 05:57:28 UTC 2017

On 05/08/17 07:52, Eduard Bagdasaryan wrote:
> To avoid this 'going around releaseRequest() API' I would like
> to suggest renaming 'RELEASE_REQUEST' flag to something
> more suitable, e.g., 'ENTRY_REUSABLE' and adding a helper
> API avoiding direct flag manipulation.

I don't see how renaming would help much. Any API control over use of a 
flag can be added regardless of its name.

Also, the 'RELEASE' flag value being true indicates REUSABLE false 
value. So the rename implies a careful and complete inversion of all 
logic conditions relying on or otherwise touching the flag. Which risks 
many new bug additions.

If done at all I think the rename should be left out-of-scope for this 
PR / patching.


More information about the squid-dev mailing list