[squid-dev] [PATCH] Make Squid death due to overloaded helpers optional

Alex Rousskov rousskov at measurement-factory.com
Thu Aug 11 14:27:58 UTC 2016

On 08/11/2016 06:53 AM, Amos Jeffries wrote:
> On 11/08/2016 11:50 p.m., Eduard Bagdasaryan wrote:
>> 2016-08-10 19:03 GMT+03:00 Alex Rousskov
>> <rousskov at measurement-factory.com>:
>>> As Amos has noted, we do need to restore the old "unknown" behavior when
>>> the helper is _missing_ (and not overloaded), but that is a completely
>>> different problem with a simple solution: SubmissionFailure() should use
>>> Helper::Unknown when its hlp parameter is nil and Helper::Error.
>> Adjusted accordingly and updated the patch.

> Since we seems to have consensus that the 'err' value means ERR, and
> other codes will be added later.
> The config value should likewise be the result code, uppercase "ERR",
> and the wording "responded with an error" be "responded with ERR". That
> makes it crystal clear that whatever the helper ERR handling is will happen.

I agree. Please use "and the helper immediately replied with an ERR
response" wording.

> If there are no further objections, I will apply it tomorrow (~12hrs)
> with the above change.

No objections from me. While committing:

> +    callback(data, hlp ? Helper::Reply(Helper::Error) : Helper::Reply(Helper::Unknown));

If possible, move the tertiary operator inside Helper::Reply(...) to
avoid "Helper::Reply" code duplication:

  Helper::Reply(hlp ? Helper::Error : Helper::Unknown)

>  	This options sets default queue-size option of the url_rewrite_children
>  	to 0.
> +

Please undo this non-change.

Thank you,


More information about the squid-dev mailing list