[squid-dev] [PATCH] Accumulate less

Amos Jeffries squid3 at treenet.co.nz
Thu Apr 28 00:39:30 UTC 2016

On 28/04/2016 5:14 a.m., Alex Rousskov wrote:
> Hello,
>     The attached patch changes Squid to accumulate fewer unknown-size
> responses to avoid overwhelming disks.

Yay. Thanks very much for this.

+1. I just have some polish to consider doing on merge.

in src/MemStore.cc:
* extraneous empty line removal.
 - IMO it reads better with that line as-was.

in src/fs/ufs/UFSStoreState.cc:
* please add whitespace around the '>' to improve debugs readability a
bit. s/">"/" > "/

in src/store/Controller.cc:
* please consider updating to C++ casts or removing entirely the C-style
casts in updateLimits().


More information about the squid-dev mailing list